Wednesday, August 18, 2010

OBIEE11g Deploying an new RPD.

Goto the weblogic EM console:

image

Expand 'Business Intelligence' node on the left and choose Coreapplication.

image

image

Now click on the Deployment tab on the right. Next, go to the Repository tab.

image

Click on 'Lock and Edit Configuration' to enable you to change the default settings.

image

Select the RPD you want to use:

image

Enter ther RPD passwords and press update:

image

Press Apply:

image

You might see a name change:

image

Click on Activate Changes:

image

image

Click on top of the page on link „Restart to apply recent changes‟. This only takes you to the page where you can restart services.

image

image 
Click on blue button „Restart‟ (or green button „Start‟) under the Manage System category, middle of screen,
image

Click yes on dialog box to confirm the move. Wait for message that confirms successful restart.

image

Have Fun:

image

Till Next Time

25 comments:

Stefano said...

Nice, but what about adminstration tool? Seems not available udner Linux and you can't install CLIENT software only under Windows to get only Administration Tool. Any hint?

John Minkjan said...

@Stefano,

Sorry, I'm still only a windows man

Iwan said...

Hi John,

Do you know the password for SampleAppLite.rpd?

Thanks...

Data Entry Services said...

Thanks a million. I never knew how to do that. Very detailed and help post!

Laszlo said...

Hi,

I also want to know the repository password for SampleAppLite.rpd

Thanks
Laszlo

John Minkjan said...

Check here:
http://obiee101.blogspot.com/2010/08/obiee11g-sampleapps-password.html

Anonymous said...

Hi I get the following error messages. Help appreciated.

Error SEVERE: Element Type: BI_INSTANCE, Element Id: coreapplication, Operation Result: FAILED_TO_START, Detail Message: Error in starting one or more components of BI Instance; Please check the server log files for detailed message.
Error [nQSError: 13037] Cannot connect to FMW Security Services, please make sure this is running in EM.
Error [nQSError: 13037] Cannot connect to FMW Security Services, please make sure this is running in EM.
Error [13037] Cannot connect to FMW Security Services, please make sure this is running in EM.
Error [71071] An attempt to establish a connection with Oracle BI Scheduler caswow102509:9705 (monitor po

Anonymous said...

Hi John - how do I start the presentation service. I do not seem to be able to access localhost:9704 and all oracle services seem to be up in services.msc

Anonymous said...

Are the steps for setting up another instance of analytics server are same as earlier?

Anonymous said...

Hi Thanks.

I have this error too:

SEVERE: Element Type: BI_INSTANCE, Element Id: coreapplication, Operation Result: FAILED_TO_START, Detail Message: Error in starting one or more components of BI Instance; Please check the server log files for detailed message.

S said...

Did you find a solution to the last error discussed?

John Minkjan said...

@All,

My experience with setting up OBIEE on fwm is very limited, this is ussally done trough our Oracle department or directly by Oracle. Quickest way is to submit a SR with Oracle if you are stuck.

Regards

Anonymous said...

Hi John,

I followed your steps in installing 11g and able to login into OBIEE and weblogic EM console, but iam not able to see the folders or nodes (1) Application Deployments 2) Weblogic Domain 3) Busniess Intelligence 4) Metadata Repositories) in the EM console so that i can change the RPD. I don't know whether i missed anything during the installation to see these folders.
Please can you let me know if i missed anything to change the rpd to SampleAppLite.rpd.

Thanks
Ajit

James said...

Thank you for your helpful blog. Is there a way to deploy a new RPD but not have _0001 or _0002 (etc) on the end of the file name? I want it to be FileName.rpd not FileName_0003.rpd. Thanks!

Dovi Lilling said...

@stefano, look at this for the client tools only on windows:
http://oraclebiblog.blogspot.com/2010/11/obi-11g-client-tools-only-install-work.html

Roberto said...

Hi,

Is there a way to do this without the EM?...via command line, for instance... I say this because I cannot access coreapplication...Maybe because of poor performance of my server, I click on coreapplication but then nothing happens, which has the sad consequence that I cannot change the .rpd that OBIEE uses or change to a newer version of the same .rpd.

Any help would be much appreciated

Regards and thanks in advance.

Anonymous said...

I got the Failed_to_start error also. i just changed the password back to Admin123 and it worked. My issue ended up being the actual Administrator password. Because my OBIEE is configured with OID following chapter 3 in the Security Guide, i had to use BISystemUser and not Administrator. I got in after that. Thanks for this post. i've learned much from this experience.

Anonymous said...

Same kind of question as stefano: is there a way to publish a new version of the RPD via command line (on unix) ? This is for scripting.

Anonymous said...

Roberto, sorry.

John Minkjan said...

Yes, have a look at weblogic scripting

regards

John

Manoj - Image Processing Services said...

absolutely true...

bhashkar_BIM Services said...

great information...............

sketchup4architect said...

Hey, I'd really like to see some of your work! Maybe we can post it up on

Manoj Singh said...

Very interesting information!Perfect just what I was searching for!

Anonymous said...

Thanks John for all of these great posts, really appreciated.